Please Update Rated 5 out of 5 stars

When first installing FF 11. It did not show any issues with your program. Then I restarted it finding Privacy Suite was not compatible with FF 11 and disabled. If they told me in the beginning I would not have upgraded to FF 11. I have all my Log Ins and opt outs on Privacy Suite. Now I can't remember half of my passwords. Please update ASAP so I can get onto my sites again. It's not you. It's Mozilla. Please HELP I NEED MY PRIVACY SUITE BACK!!!!!!!!!!!!!!!!!!!!!!!

This review is for a previous version of the add-on (0.744).