Rated 4 out of 5 stars

This is very easy to fix for FF 3.5.5 and 3.6.
Simply Download this from "another" Browser, open with Winrar, click on Install.rdf, then change the max version to 3.7 or anything higher, save and close Winrar.
Open Add ons and drag the new and modified xpi file into the Ad ons.
Reboot Firefox and you're good to go.
This works with any incompatible Extensions for the newer versions of Firefox.
It's obvious that some Developers are slow updating their Extensions/Ad ons, so don't bother waiting., just update them yourselves!

This review is for a previous version of the add-on (0.6).