Rated 4 out of 5 stars

You can make it work by changing the version number to 3.6.*
Just D/L the ext, open with winrar or similar, extract install.rdf, open in noteopade and look for:
3.5.*
edit that, save and put it back into the XPI (which is just an archive). Presto, install and it works.

This review is for a previous version of the add-on (0.7.1.4).