Rated 2 out of 5 stars

This is killing me, does anyone have a replacement for this add-on that works in 3.6, 3.7 and/or 4?

Please update... This extension is an absolute must have for me. Quite honestly, it should not be needed, this is a basic item that should be built into Firefox. But since it's not......

Can only give it 2 stars now since I have to disable compatibility checking for every FF installation and profile I have:(