Please revise to work with 3.6 Rated 5 out of 5 stars

I am also holding off on updating to 3.6 until this wonderful add-on is revised to work with 3.6