Not compatible with minor version of 3.5 Rated 3 out of 5 stars

Although this add-on is listed to work with 3.5* after I installed it my FF still barks that it's not compatible with 3.5.1