Rated 3 out of 5 stars

please update! not currently compatable with the most recent version of firefox :(

This review is for a previous version of the add-on (1.2.10).