install failed Rated 1 out of 5 stars

2 May 2010 downloaded POW v0.1.9 into FF 3.6.3 - install failed. The install.rdf file still says MaxVersion is 3.5 . I edited it to 3.6.* but it still doesn't work. FF > Tools > Add-ons > is frozen with a bleep for every click.

This review is for a previous version of the add-on (0.2.1).