Rated 3 out of 5 stars

Pop Block 1.0.0 isn't compatible with FF10.0.11 ESR. The version information is mistaken.Version Information:Version 1.0.0 Released December 3, Works with Firefox 10.0 and laterSome minutes later, I installed it in FF 17.0.1 ESR, and for using, you must login on Twitter or on Facebook. I don't use either.

This review is for a previous version of the add-on (1.0.0). 

Greg Leuch, Creator

Thanks FastKC for the feedback. Although we were able to get it working under 10.0 for Mac, we've updated the minimum version.

After some discussion, we've decided to alter our product strategy and allow normal user signups. Click on "signup with email address" to do it the old fashion way. https://pop-block.com/signup