44 reviews for this add-on
  • platypus allowed the less than savvy user to rearrange pages to one's own liking. Such power is typically reserved for UserScript authors fluent in XPath and related queries, or those with a CSS penchant (ala Stylish)

    There exists a need for proponents of adblocking (AdBlock Edge, karma blocker) to collapse- or move elements. With AdBlock Edge (ethical tinkering adblock "plus") one can remove ads from a div but not collapse the div [to retain space in interweb email]

    hopefully some brave, charitable soul will resume development of Platypus. Perhaps one that plays extremely well with privoxy functions?

    Such a new platypus would do well to output for userscript (as is), but also pure CSS (into stylish) and some bits into AdBlock Edge.

    $0.03

    massive kudos to Scott R. Turner

  • for mirror of Platypus version 0.82
    http://forum.addonsmirror.net/index.php?showtopic=3404

    "1. Scroll down to the bottom of this page and click "View all Versions" link, install Platypus 0.82 from there and close Firefox. (See mirror link above, install)
    2. In address bar type about:support and press Enter; and then click Open Containing Folder. (Easy way to figure out location of your Firefox profile folder)
    3. From there go into extensions folder and then into {a089fffd-e0cb-431b-8d3a-ebb8afb26dcf} folder.
    4. Copy file downloaded from this link: - http://www.mediafire.com/?8e11jjkp9lz736o - to your {a089fffd-e0cb-431b-8d3a-ebb8afb26dcf} folder..." - quote from niko32

    mediafire file (source) below... [in case file disappears].


    /* save below code as text file, then rename to - chrome.manifest - see reviews further below for more info... */


    overlay chrome://browser/content/browser.xul chrome://platypus/content/platypusOverlay.xul
    overlay chrome://navigator/content/navigator.xul chrome://platypus/content/platypusOverlay.xul
    content platypus jar:chrome/platypus.jar!/content/platypus/

    skin platypus classic/1.0 jar:chrome/platypus.jar!/skin/classic/platypus/
    style chrome://global/content/customizeToolbar.xul chrome://platypus/skin/toolbar-button.css

    locale platypus en-US jar:chrome/platypus.jar!/locale/platypus/en-US/

    locale platypus de-DE jar:chrome/platypus.jar!/locale/platypus/de-DE/

    locale platypus en-US jar:chrome/platypus.jar!/locale/platypus/el-GR/

    locale platypus en-US jar:chrome/platypus.jar!/locale/platypus/es-ES/

    locale platypus fr-FR jar:chrome/platypus.jar!/locale/platypus/fr-FR/

    locale platypus it-IT jar:chrome/platypus.jar!/locale/platypus/it-IT/

    locale platypus nl-NL jar:chrome/platypus.jar!/locale/platypus/nl-NL/

    locale platypus en-US jar:chrome/platypus.jar!/locale/platypus/pt-BR/

    locale platypus zh-CN jar:chrome/platypus.jar!/locale/platypus/zh-CN/

  • Some time ago i made a version that added Firefox 4 compability.Now im updating this up to version 8.0 compability.

    So should work fine in 6.0 - 7.0 and 8.0.Just download and open it with firefox.You will be prompted for install.So even on Firefox 8 you won't get any incompability warning.Also changed version to 0.83.Working nicely here on 6.0:
    http://www.mediafire.com/file/p9q18ji01ccsc6g/%5BPlatypus%5D%20v.0.83.xpi

  • Once again, this add-on will work with FF 5, simply needed to modify the version number. If you don't want to mess with that yourself, you can download an updated copy of Platypus here (merely changed the version number in the install.rdf file, added my name to it):

    http://bit.ly/Platypus_v082_WorksWithFF5_xpi

    MD5: 1EF96E21CB728EB2412FC3C06818EE11
    SHA1: EA39407158E1A844AB10D2B2C478B9ED1EA80360
    CRC32: BC80F765

  • Im still using the following addon which allows to HIDE specific elements of a website using Add Block Plus:
    https://addons.mozilla.org/de/firefox/addon/elemhidehelper/?src=collection&collection_id=162d7314-da31-4f38-8df8-4a7892200b54
    But still, Platypus has way more usefull options to personalize single websites.
    5 stars, allthou Im still waiting for support for Firefox 5+

  • First off, I can't believe more people don't use Platypus - I loves loves loves it. Second, a HUGE thank you to @RaXelliX for getting it working for FF4, I am grateful someone else did what I am probably too lazy to do.

    I was in communication with Scott (the author of Platypus) some 7 months ago, asking if I could help get it updated, but got very busy soon after. I just wrote to him to find out if anything has changed with it, maybe I will get things going on it...but then again, maybe not. :)

  • Why the FF4 version is not official? I would like to see.

  • Thanks to RaXelliX for the updated version :)

  • pun intended

  • Update to FF 3.6.11 ?

  • 1. Scroll down to the bottom of this page and click "View all Versions" link, install Platypus 0.82 from there and close Firefox.
    2. In address bar type about:support and press Enter; and then click Open Containing Folder. (Easy way to figure out location of your Firefox profile folder)
    3. From there go into extensions folder and then into {a089fffd-e0cb-431b-8d3a-ebb8afb26dcf} folder.
    4. Copy file downloaded from this link: - http://www.mediafire.com/?8e11jjkp9lz736o - to your {a089fffd-e0cb-431b-8d3a-ebb8afb26dcf} folder.

    Thanks to "TheSilverOne" for the file from his profile that made me figure this out. Last thing on my mind was to build my heavily customized Firefox profile from scratch because of 1 add-on. :( Luckily the problem was rather simple: missing chrome.manifest file for Platypus add-on.

  • Confirmed! Workaround for firefox 3.6

    http://silverwav.wordpress.com/2010/06/08/platypus-workaround-for-firefox-3-6-use-a-firefox-3-5-profile/

    1. The Problem.
    What to do when Platypus will no longer work with Firefox 3.6?
    2. The Solution.
    * Platypus works fine with Firefox 3.5.9.
    * So create a profile and install platypus with Firefox 3.5.9.
    * Now upgrade to Firefox 3.6.
    Yeah! It still works!
    3. Quick Hack Here.
    Use the blank profile I have created for my own use here.
    http://shelvelogger.googlegroups.com/attach/eb4782445ba6a835/firefox-3.6.5profile_platypus.zip?part=2

  • Tried "bump version to 3.6.*" and tried to install Platypus 0.82 that is supposed to be working with Firefox 3.7. Did not work. And every time I tried to open Platypus options, my Firefox got frozen.

  • http://silverwav.wordpress.com/2010/06/08/platypus-workaround-for-firefox-3-6-use-a-firefox-3-5-profile/

    1. The Problem.
    What to do when Platypus will no longer work with Firefox 3.6?
    2. The Solution.
    * Platypus works fine with Firefox 3.5.9.
    * So create a profile and install platypus with Firefox 3.5.9.
    * Now upgrade to Firefox 3.6.
    Yeah! It still works!
    3. Quick Hack Here.
    Use the blank profile I have created for my own use here.
    http://shelvelogger.googlegroups.com/attach/eb4782445ba6a835/firefox-3.6.5profile_platypus.zip?part=2

  • Works with 3.5.9
    Workaround1 for 3.6* is to use the 3.5.9 profile, then "make compatible" with Mr Tech Toolkit)
    Workaround2 for 3.6* is to use the 3.5.9 profile, then "bump version to 3.6*" open the xpi (with a zip manager), alter the "max version" line in the file "intall.rdf" (with a text editor), then save changes, restart firefox.

  • Please give us an update of platypus so that it can be run on firefox 3.6.thanks

  • It's too bad that this is no longer being supported. I used Platypus extensively throughout the day and it had become an integral part of my workflow. Sigh...

  • there IS a new version, click the View All Versions link under Release notes *I tried it, and the latest version doesn't work...*

  • Version 0.82 — October 7, 2009 — 225 KB
    Works with:

    * Firefox: 0.3 – 3.7a1pre

    See all older version

  • I just wanted to pass this information on to you folks who are hoping to see this extension updated for more recent versions of Firefox. I emailed the author directly and this was his response:

    On Fri, Feb 12, 2010 at 6:07 AM, Mulsiphix wrote:
    > Hello! I was just curious if you had any plans to
    > update Platypus anytime soon for FireFox v3.6?

    On Fri, Feb 12, 2010 at 3:55 PM, Scott Turner wrote:
    > No, I don't think so. The Firefox folks are asking for
    > some major changes to extensions for 3.6 and I'm
    > not sure when (if ever) I'll have the energy/time to
    > update Platypus. Sorry!

  • Great add-on! Been using it for years, mainly for cleaning pages for printing, etc. Problem is, it doesn't get updated enough. Now I'll have to hack it and hope it doesn't damage anything...

  • This is a great add-on (once you understand how to use it). I do hope that it gets updated to the latest Firefox versions, though.

  • Not compatible with Firefox 3.6. Can we get an update please?

  • I have to give this only 1 or 2 stars because:
    Now I have "platypus!" in my right click menu. Whoooot? I never remember that it means "edit page".

    PLEASE, change the name of the extension/addon to be such that it DESCRIBES WHAT THE ADDON DOES.

    And make the menus simpler, too many buttons, remove some crap.

  • This is Ok at least with Firefox 3.0.

Page 1 of 2