Very nice and mandatory (Helpful) Rated 5 out of 5 stars

This tool is mandatory to work with KDE and Firefox - so the Passwords are stored in a standard way. Works with all Firefox versions < 7, but 7 is not supported now (2011-10-03)