Firefox 4 Rated 5 out of 5 stars

For all worrying of compatibility issues in Firefox 4 : you don't need this extension anymore.

Go to "about:config" in your address bar. Search for "ui.", then turn the "ui.use_native_popup_windows" key value to true. That's it. Enjoy your plasma notifications again.

This review is for a previous version of the add-on (0.3.1).