FF16 needs another version Rated 5 out of 5 stars

I just updated to FF16 and the addon became incompatible.
I tried the version 1.2.1 from this link:
http://www.iosart.com/firefox/plainoldfavorites/
it is working fine, PlainOldFavorites is working in FF16 with this. cool!