Working again Rated 5 out of 5 stars

Yesterday I updated my backup machine to FF 15. As usual, POF was flagged as incompatible. Also as usual, in about a day it became compatible with no update shown. If you can't wait, install the Nightly Tester Tools which allows you to bypass the test, though FF will still show what it thinks are incompatible.

This user has other reviews of this add-on.