POF and FF11 Rated 5 out of 5 stars

I had the same problem. My solution:
Change the value "maxVersion" to 14.0
( <em:maxVersion>14.0</em:maxVersion> )
at the "install.rdf" file located in the extension folder of POF