Don't work with FF 28.0 Rated 4 out of 5 stars

Addon not work

This review is for a previous version of the add-on (1.8.0.1-signed).