Rated 4 out of 5 stars

Same problem for me with FF3.6 and PP1.5.5 with Win7. Well, I went back to PP1.1.0 and just edited the install.rdf to comply with FF3.6. It works perfectly! :) I just wanted the new features. Guess I'll have to wait.

This review is for a previous version of the add-on (1.5.5).