Rated 5 out of 5 stars

Firefox 3.6 would not successfully update to PitchDark 3.62. Uninstalling older version of PitchDark and then newly installing 3.62 worked.

This review is for a previous version of the add-on (3.6.2).