Rated 5 out of 5 stars

I loved this theme, but it is not compatible with firefox 3.....PLEASE update it. Thanks!

This review is for a previous version of the add-on (1.0.6).