Works with FF 7.* Rated 5 out of 5 stars

Open *.xpi file with 7zip, and edit file install.rdf
at line 83 change to
<em:maxVersion>8.0.*</em:maxVersion>
save this and drag and drop to the browser.
Thanks for the great addon

3.5 - 3.6 compatibility wanted Rated 4 out of 5 stars

What does the * by 3.5 mean?
Is 2.4 fully compatible with FF 3.5?
I don't upgrade because of this.
Please state it clearly.
After all, the extension is handy, thanks.

translation suggestion from Google or FoxLingo Rated 2 out of 5 stars

It would be nice to have a translation suggestion from Google or FoxLingo and string reodering like in the new original.

Rated 5 out of 5 stars

Very nice !!!

please update to definitions Rated 4 out of 5 stars

I would love to be able to have a (small?) update to be able to easily translate also code based on definitions, like:
define(L_PRICE,'Price:');
define(L_PRICE_FROM,'from');
define(ONLY_PRO, 'Professional Only');

thanks a lot