works fine with 3.6 Rated 5 out of 5 stars

just install before upgrading to 3.6, also install "Mr Tech Toolkit" add-on, and use it's "make compatible" feature...

restart Firefox and re-activate Phoenity Aura 8)

This review is for a previous version of the add-on (0.4).