Please update! Rated 5 out of 5 stars

I couldn't agree more with the previous review. This extensions is abolutely great and indispensable. Please update it to make it compatible with newer FF versions!

This review is for a previous version of the add-on (4.2). 

Glad you find the extension useful. Just confirmed that it works with FF 6 and updated the compatibility, so it should be working now.