Rated 4 out of 5 stars

Its a very cool extension, unfortunately it wont let me install it in FF 3.5 beta 4 (altough it says it works from v1.5 to 3.6a1), anyway, thumb up!

This review is for a previous version of the add-on (4.1.4).