Firefox 8 and above. Rated 5 out of 5 stars

Can you add Firefox 8 support.