Necessary Add-On, but then you upgrade Firefox Rated 1 out of 5 stars

I've had this add-on for a while now, and it's been wonderful on my Mac. But, I recently upgraded to the new Firefox, Firefox 10, and it's no longer compatible. Problem! I'm a college student and now can't open the imbedded PDF files my professors like so much. When will this be compatible with the new Firefox? Until it's compatible, hopefully I'll be able to go back to the old Firefox...