Rated 5 out of 5 stars

Version 1.2.0 still working fine for me with FF 5.01 and OSX 10.6.8 and running in 64bit.

This user has a previous review of this add-on.