Rated 1 out of 5 stars

This add on Cannot be installed as it appears to be corrupt.
Needs to be fixed.

Can someone please check this and make the necessary repairs.

Thanks.

Rated 1 out of 5 stars

Still not compatible with FF 3.6!!

This review is for a previous version of the add-on (3.0.0.1). 

Rated 2 out of 5 stars

Doesn't work in FF 3.6 evgen after changing the Max. version.
Time to update, folks!

This review is for a previous version of the add-on (3.0.0.1).