Updated version now works with FF 3.6.13 Rated 4 out of 5 stars

The plugin version was apparently updated in early February (2011), without changing the version number, in order to work with Firefox 4. I don't have FF4 but am happy to report that It works for me under Firefox 3.6.13 (using Windows Vista). Maybe it helps that my default PDF software is Nitro PDF Professional (albeit the somewhat older version It is a bit slow sometimes, but it works pretty well.