Im confused Rated 4 out of 5 stars

I initially thought this extension is some kind of fix before Firefox 3.5 es released. On this page you say that this extension is for Firefox 3.0.* ~ 3.2a1pre. But additionally the compatibility is displayed as Firefox: 3.0pre – 3.6a1pre.

Now I'm confused: will I need this for Firefox 3.5 or should I uninstall before updating to 3.5?

This review is for a previous version of the add-on (6.1).