Rated 5 out of 5 stars

Love this addon. Can't use it anymore as I upgraded to FF18. Any plans to upgrade?Tried the suggestion about reinstalling addon. That solved the issue. I was getting a non-compatible with this version of FF and it was then disabled.

Already works with FF18

Can you try it in a new Firefox profile and/or disable other addons? PasswordMaker does work with Firefox 18.