Love this add-on; when available for FF8.0? Rated 5 out of 5 stars

Great add-on! I've been using it for years, and have found it absolutely indispensable.

I just tried to upgrade to Firefox 8.0, though and it disabled PasswordMaker due to version incompatibility. Any plans for releasing a compatible version soon?

Should work now

Sorry for the trouble. It should work now. Try updating your addons (about:addons in the address bar; right-click PasswordMaker; select Find Updates)