Rated 1 out of 5 stars

Trouble on Firefox 3.6 Linux: After Installing the Add-on Firefox won't start. A full re-installation was necessary! This error was repeatable on several systems.

This review is for a previous version of the add-on (1.1.6.1-signed).