Rated 5 out of 5 stars

Hi, you can install on v5.0 after using this add-on:
https://addons.mozilla.org/en-US/firefox/addon/checkcompatibility/