Thunderbird 3.1 Rated 5 out of 5 stars

Very good extension.
But it does not work with thunderbird 3.1.
It is easy to correct: unzip the file .xpi (maybe modify the extension from xpi to zip) , open the file install.rdf and change the line
zip the archive and install it.

This review is for a previous version of the add-on (1.2).