Rated 2 out of 5 stars

Please, update for FireFox 4.

Rated 3 out of 5 stars

Please, update this page too if you have a version for FF4.
We need this add-on.