Poor upkeep Rated 2 out of 5 stars

Not updated for the latest version of Firefox. This should be anticipated, they don't make a secret of new versions, plus future versions can be "pre-approved" in the add-on.
Finally, I find it highly ironic that a spell"ceck" app can't spell their own name right.

Compatable versions of Firefox

OpenMedSpel is compatible with Firefox and Thunderbird through version 32 as of 4/18/2014.

Thank you for catching the typo.