dictionary Rated 4 out of 5 stars

will an update be coming as I get an error message that it is not compatible with 3.6.3 - thanks

This review is for a previous version of the add-on (1.0.8). 

Sorry to hear you are having difficulty..

OpenMedSpel should work with versions through 3.7a3pre.

I am using Firefox 3.6.3 now without problems. Please check to make sure you are using the latest version of OpenMedSpel.