A Must Have Add-on! Rated 5 out of 5 stars

Any time I install a fresh profile of FF (whether on a new device or because I've lost patience cleaning my profile up), I usually install OpenMedSpel. For some reason, last week when I got a new profile, I did not install it. I do a lot of posting on medical related sites, or of medical items and it's great having a spell checker/dictionary that actually recognizes words I type quite often. I am glad I finally realized my problem today and remedied it! Excellent add-on for anyone who uses a lot of med terms.

Glad to hear you find OpenMedSpel useful!
Thank you for your review.

Poor upkeep Rated 2 out of 5 stars

Not updated for the latest version of Firefox. This should be anticipated, they don't make a secret of new versions, plus future versions can be "pre-approved" in the add-on.
Finally, I find it highly ironic that a spell"ceck" app can't spell their own name right.

Compatable versions of Firefox

OpenMedSpel is compatible with Firefox and Thunderbird through version 32 as of 4/18/2014.

Thank you for catching the typo.

Great add-on, please update! Rated 5 out of 5 stars

Love this dictionary, but would be great if it could be updated for latest firefox (7.x).
When I install, it says it was successful, but does not show up in list of dictionaries.

Thanks!

This review is for a previous version of the add-on (1.0.9). 

Updated

OpenMedSpel is compatible with Firefox and Thunderbird through version 32 as of 4/18/2014.

Does not work in Firefox 5 Rated 2 out of 5 stars

This add on does not work in Firefox 5, please update the add on.

This review is for a previous version of the add-on (1.0.9). 

OpenMedSpel is compatible with Firefox and Thunderbird through version 32 as of 4/18/2014.

Great, but... Rated 2 out of 5 stars

I've been using this extension since I started using Firefox and love it! The thing is I install this version with Firefox 4 and it doesn't appear with the other available dictionaries. I can see it active in the addons FF4 page, but it doesn't work. Anyone have any idea of what's happening? I'll change to 5 stars when it works correctly.

This review is for a previous version of the add-on (1.0.9). 

Help Rated 5 out of 5 stars

I download this add-on for firefox (3.6.8). The computer is Mac. I can not run it. How can I work it. Thanks.

This review is for a previous version of the add-on (1.0.8). 

Rated 5 out of 5 stars

Very nice add-on for me!

This review is for a previous version of the add-on (1.0.8). 

Extremely useful add on for medical transcription professionals textilesinfomediarydotcom Rated 3 out of 5 stars

Exception are part of redevelopment. You may check now. textilesinfomediary have appended some new words in the glossary. As a practicing Medical Transcription Expert you may contribute some more terminology to be included by us. Once again thank you by textilesinfomediary.

This review is for a previous version of the add-on (1.0.8). 

Rated 4 out of 5 stars

Easy to install and useful. Sometime bizarre (e.g. no "myocarditis" "bronchopneumonia" "osteoclast" but include "myocarditic", "osteoclastic" in the dictionary). It will nice if the raw file of dictionary can be edited directly.

This review is for a previous version of the add-on (1.0.8). 

Thanks for the comments and the words to add!

The dictionary file name is OpenMedSpel.dic and it can be edited with any text editor.

The raw dictionary file can be found in -
C:\Documents and Settings\**your account name**\Application Data\Mozilla\Firefox\Profiles\id8ro0eb.default\extensions\openmedspel@e-medtools.com\dictionaries

dictionary Rated 4 out of 5 stars

will an update be coming as I get an error message that it is not compatible with 3.6.3 - thanks

This review is for a previous version of the add-on (1.0.8). 

Sorry to hear you are having difficulty..

OpenMedSpel should work with versions through 3.7a3pre.

I am using Firefox 3.6.3 now without problems. Please check to make sure you are using the latest version of OpenMedSpel.