Update Compatibility Rated 5 out of 5 stars

Please update compatibility for newer versions of Firefox