Addon Compatibility Reporter Rated 5 out of 5 stars

Works with Firefox 4. Just install addon
Add-on Compatibility Reporter. Restart the browser and then try installing any addons you want.

This review is for a previous version of the add-on (2.1.5).