Rated 5 out of 5 stars

I would dearly love to have this plugin, but attempting to Download/Install generates the error-message:

"OpenBook 2.0.1.1 could not be installed because it is not compatible with Firefox 3.6.13."

I am perplexed & vexed by the Paleolithic design elements of Firefox' bookmark (so-called) Dialogs. Won't move. Can't resize. Waayyy to small.

Strange. Fortunately, I accept 80% solutions ... and FF is at least 97%. ;)

This user has a previous review of this add-on.