Rated 5 out of 5 stars

It was great,
but v.501 does not work with Firefox 3.6.15 (latest),
under XP-SP3.

Went back to "Open With" version 5.0.

btw:
just like many other people,
I will stick with Firefox 3.6 series,
until FF 4 "stabilizes", in the future.

(I love my FF extensions *too much*, to jump into the FF 4 hoopla & extensions headache...).

SFdude

This review is for a previous version of the add-on (5.0.1).