New version for Firefox 6.0? Rated 5 out of 5 stars

Yes, please update this *excellent* extension to work with Firefox v. 6.0. I just updated the browser, and I miss it already!