No need to modify Rated 5 out of 5 stars

As I have tested it out on my Win7 x64 PC, this add-on can work under Firefox 4.0.1 without the modification described below by Stu Berg. What you only need to do is to force the installation, i.e., to make Firefox 4.0.1 ignore the version incompatibility.

The procedure is as follows:

about:config --> right-click on some empty area to invoke the context menu --> select "New" --> select "Boolean" --> fill in "extensions.checkCompatibility.4.0" (without quotes) for the preference's name --> set the value to false

After doing above, you can add this extension to Firefox without seeing the "...could not be installed..." message.