Can't install for new version of Firefox Rated 5 out of 5 stars

Can you please make a version that works with Firefox 3.5? I can't install the older version, and I really liked it since Netflix only shows their movies in IE.

This review is for a previous version of the add-on (1.1).