Rated 5 out of 5 stars

Working fine for FF 6.0a1 after editing max version in .rdf file to allow install.

This review is for a previous version of the add-on (1.0.2).