Firefox 57 Rated 5 out of 5 stars

I have followed the instructions but it does not work with Firefox Quantum 57+.

It shows a message and says that the extension is not compatible with Firefox 57, i've enabled the extensions legacy, restarted the browser and it failed on Quantum.

On Firefox Dev edition it worked well.

This review is for a previous version of the add-on (5.1.1).  This user has a previous review of this add-on.

Firefox Developer Edition = "Blueish" Quantum :)

Instructions on https://noscript.net/faq#qa2_1 explains that you need a blueish 57 (Firefox Dev Edition) or 58 (Nightly) for the extensions.legacy.enabled preference to work. Beta ("orange" 57) doesn't work.