Rated 5 out of 5 stars

Who are you really hurting by not updating the theme, Mozilla or the hundreds of thousands of users that have been using your theme for years? I'd be happy to contribute, but not if I can't use it with Firefox 4. Please reconsider who you are really hurting!!