Setup Info Rated 5 out of 5 stars

I found out why. About:config is missing this line. Set it to false
extensions.checkCompatibility.17.0

Then install whatever you want.

This review is for a previous version of the add-on (3.3).  This user has a previous review of this add-on.