Broken Rated 2 out of 5 stars

Firefox 3.6.23 on Solaris 10 SPARC system

I agree with QueenOfStars writing on August 24, 2011

"the version numbering is off; you went from 3.1.7 back to 3.1.5.1 and it doesn't auto-update anymore."

The "make compatible" button no longer displays on the Add-ons menu and Force Addon Compatibility option from the Tools->Nightly Tester Tools menu does nothing.

Is there a plan to fix this and when will this be updated for Firefox 7?

This review is for a previous version of the add-on (3.1.5.1).